Plötzliche Updateprobleme bei Siedler 3

Ouf. Kürzlich habe ich mir nen zweiten Rechner (nen AMD K6-III mit 450 MHz, hehe) abgeholt (gabs umsonst), um mit meinem Bruder (Pierre) hin und wieder mal über LAN ne Runde Counterstrike oder Siedler zu daddeln, also um meinen Erstrechner (nen Celeron mit 433 MHz, ebenfalls hehe, aber für meine Zwecke reicht er halt noch) mit einem Zweitrechner zu vernetzen.
Nicht ganz unkompliziert, das ganze, und schon bei der Siedler 3 – Installation gabs nicht erwartete Probleme.
Nachdem ich via ebay den AMD noch mit nen bisserl Speicher und vor allem dem Netzwerkkabel ausgestattet hatte, installierte ich also dort Windows 2000 (die Probleme, Soundkarte und Netzwerkkarte zum gemeinsamen Betrieb zu überreden beschreibe ich jetzt besser nicht…), lud mir die 520 Gigabyte an Windowsupdates runter (um dort auch endlich die neuen Sicherheitslücken freizuschalten), und war frohen Mutes, dann dort auch einfach Siedler 3 installieren zu können.

Wurde aber leider nichts. Bei mir auf dem Celeron läuft natürlich längst die aktuelle Siedler 3 – Version (1.60), die bei mir problemlos startet und dann auch ebenso läuft.
Auf Pierre seiner Siedler-CD liegt Spielversion 1.23 vor, welche dementsprechend ebenfalls auf die aktuelle Version gepatcht werden muß, damit er mit meinem Siedler eine Verbindung aufbauen kann.

Auf Pierres AMD sieht das, was die Lauffähigkeit der aktuellen Version betrifft, komplett anders aus: Dort startet die alte Version 1.23 problemlos, mit der er sich natürlich nicht mit meinem Siedler in Version 1.60 verbinden kann, weil eben nur zwei gleich gepatchte Versionen Kontakt miteinander aufnehmen können.

Dementsprechend starte ich dort dann das Update für Version 1.38 und älter auf Version 1.60, welches ich mir zuvor von ftp://ftp.bluebyte.com/updates/s3old160.exe heruntergeladen habe. Anschließend startet dann die Version dort nicht mehr. Fehlermeldung:

S3
Bitte legen Sie DIE SIEDLER III CD1 oder die GEHEIMNIS DER AMAZONEN CD in Ihr Laufwerk und versuchen es erneut!“
OK

(und das gleiche nochmal in englisch).

Das die CD dort natürlich bereits drinne liegt, versteht sich von selbst, und am CD – Laufwerk liegt es auch nicht, denn das war vor dem neuen Rechner bei meinem Rechner eingelegt und hat dort meine Siedler 3 – CD problemlos erkannt.
Achja, auch mit meiner Siedler 3 – CD kriege ich es auf Pierres Rechner nicht gestartet. Und auch nachdem ich alle meine Files der bei mir lauffähigen Siedler 3 – Installation auf Pierres Rechner kopiert hatte, lies sich dem seine Installation dort nicht mehr starten. Weder mit seiner, noch mit meiner CD. Das soll mal bitte jemand verstehen…

Bin ich nun eigentlich gezwungen, auf Pierres Rechner sowas illegales wie einen NoCD- Crack zu benutzen, um auch dem seine Installation nutzen zu können? Ich habe noch nicht gezielt danach gesucht, aber bei einem ersten Schnellsuchgang konnte ich leider nichts finden. Aber wenn das so weiter geht, steigt die Versuchung, meine legal erworbene Software auch zum Laufen zu bekommen… Leider liegt der CD-Kauf schon zu lange zurück (halt noch aus der Zeit, bevor mein Bruder sich seinen Rechner hat klauen lassen, also etwa 3 Jahre), sonst käme ich tatsächlich jetzt auf die Idee, nach dem Produkthaftungsgesetz zu suchen, um mal nachzulesen, was da zum Thema „Gebrauchsfähigkeit“ steht.
Kann ja irgendwie nicht im Sinne des Erfinders sein, dass man illegale Tools einsetzen muss, um legal erworbene Programme auch benutzen zu können…

In einem letzten Versuch werde ich jetzt mal den Hersteller kontaktieren, mal schauen, was der dazu meint – ich werde drüber berichten…. Edit von 16:50 Uhr: Nach einer weiteren Installation vergass ich das testweise Starten nach dem installieren und machte direkt das Update auf 1.60 (natürlich mit unter Windows scheinbar obligatorischem Reboot), und als ich dann Siedler startete, startete es tatsächlich, meckerte also nicht mehr wegen einer angeblich nicht vorhandenen CD herum. Dass das nun wirklich daran lag, dass ich vor dem allerersten Spielstart erst das Update aufgespielt habe, glaube ich zwar nicht (dann hätten die Spieler damals vor dem ersten Programmstart ja auch erst auf das noch erscheinende Update warten müssen, lol), aber nun gut, jetzt funktioniert es jedenfalls. Halt Windowsprinzip, man muss die Dinge bloss oft genug neu installieren, wenn irgendwas nicht funktioniert, irgendwann geht es dann, ohne das man etwas anders gemacht hätte…

Leave a comment

0 Comments.

Leave a Reply


[ Ctrl + Enter ]


%d Bloggern gefällt das: